New release Jakarta 2017.124


#1

Dear users,

we tagged a new release of SeisComP3 Jakarta: 2017.124. Binaries for various
operating systems have been built. The full source is available at Github
[1]. Please read the changelog [2] and some more info [3] for a list of fixes and changes. All gempa
GmbH customers will find binary packages in their repositories.

Have fun,
Jan

[1] https://github.com/SeisComP3/seiscomp3/archive/release/jakarta/2017.124.zip
[2] https://github.com/SeisComP3/seiscomp3/blob/release/jakarta/2017.124/CHANGELOG.md
[3] http://www.gempa.de/news/2017/5/8/seiscomp3-release-jakarta-2017-124/


#2

blockquote, div.yahoo_quoted { margin-left: 0 !important; border-left:1px #715FFA solid !important; padding-left:1ex !important; background-color:white !important; } Dear users,

I want to install the SeisComP3 on CentOS 6.8 What are the steps to install.

Best regards,
Yasmin.

| | jabe
June 2 |

Dear users,

we tagged a new release of SeisComP3 Jakarta: 2017.124. Binaries for various
operating systems have been built. The full source is available at Github
[1]. Please read the changelog [2] and some more info [3] for a list of fixes and changes. All gempa
GmbH customers will find binary packages in their repositories.

Have fun,
Jan

[1] https://github.com/SeisComP3/seiscomp3/archive/release/jakarta/2017.124.zip
[2] https://github.com/SeisComP3/seiscomp3/blob/release/jakarta/2017.124/CHANGELOG.md
[3] http://www.gempa.de/news/2017/5/8/seiscomp3-release-jakarta-2017-124/

Visit Topic or reply to this email to respond.

You are receiving this because you enabled mailing list mode.

To unsubscribe from these emails, click here.


#3

You will find the steps necessary for an installation in the documentation. It is also available online.


#4

Hello there.

I’ve installed the latest Jakarta 2017.124 version. What I like most is to enable Local Time instead of UTC.

But I guess there is a bug on SCESV. If you enable local time on SCESV it will change origin time to local time instead of UTC, but origin time still showing the time signal UTC.

How to fix this? Should I wait for next update?

Thanks.


#5

Good catch, thank you. That will be fixed and you can grab the change from Github to compile yourself or wait for a new update package. I think we will integrate that as a hotfix into the current 2017.124 package.


#6

You can compile from https://github.com/SeisComP3/seiscomp3/releases/tag/release%2Fjakarta%2F2017.124.02 if you want. This includes the fix for the issue you mentioned.


#7

any instruction how to compile, please? :smiley:


#8

Here :wink:


#9

Either download the source from the release page (https://github.com/SeisComP3/seiscomp3/archive/release/jakarta/2017.124.02.tar.gz), extract and proceed with compiling instructions at point 3 or use Git and checkout the tag release/jakarta/2017.124.02 (as given in the instructions).


#10

EDIT:

MANAGED COMPILE…
Now it’s true local time

THANKS!!


#11

I know that I opened Pandora’s box with my recommendation to compile the package yourself. You have to install cmake and cmake-curses-gui. Package names may be different on your system. We will provide binary packages soon, so stay tuned if you do not manage to compile on your machine.


#12

Dear all
I just compiled the new SC3 release in my Debian 8 64 bits, but I was not able to add the ipgp-addons. I just got an error with this package. When I turn off the ipgp-addons . Everything goes fine.
Any idea
Regards
Manuel


#13

You should describe the error you are getting. And the ipgp-addons are not part of SC3. The SC3 API has changed so it is very likely that external addons won’t compile any longer. Please contact the authors, e.g. @saurel. I will be available if questions arise regarding the port.


#14

Jan, Manuel,

I haven’t had the opportunity to try this latest release and port the ipgp-addons to it yet (I’m back from the field only since Tuesday).

I will try to have a look at it soon.
However, Manuel, as Jan says, it would help if you can provide the error messages.

Regards.

Jean-Marie.


#15

Hi Jean Marie and Jan
Here I am sending a file containing the output of the complete compilation process
I hope it can help.
Regards

Manuel

compilation-output.txt (164.6 KB)


#16

Manuel,

Thanks, I see a first issue.

In the previous releases, the method stringify was in an IPGP addon library.

Now, the same method stringify has been included in the main SC3 libraries, so I will need to change the include statements in ipgp-addons to search for stringify from SC3 library and I will have to remove the method from IPGP addon library.

Regards.

Jean-Marie.


#17

Manuel,

In fact it seems I already applied the necessary changes to the ipgp-addons code in late April.
At least, the latest version from ovsm-dev github associated to the latest seiscomp3 github clone compile successfully.

Can give a try by using a fresh ‘git clone’ from ovsm-dev ipgp-addons repository ?

Saludos.

Jean-Marie.


#18

I have updated the fork on SeisComP3, it is now in sync with ovsm-dev. @mcutie, please pull again the ipgp-addons and try again.


#19

Dear Jan and saurel
I will try it and I will let you know.

Regards

Manuel


#20

Dear Saurel and Jan
I just compiled the ipgp-addons from ovsm-dev and it works fine
Thank you very much for your help

Regards
Manuel