New release Jakarta 2017.124


#41

Andres,

Thanks, it works.


#42

Dear Mr.Wewenk ,

Salam Hormat…

i am indonesian like you :smiley: , i want to discuss about sc3 2017 with you sir, can i get your contact ?.

i can’t acces bmg ia , gak tau kenapa pak, inventory,dll udh betul semua, cuman ge aja yg bisa ral time.
mohon sangat bantuan nya pak :slight_smile:

best regards
terimaksih banyak


#43

have anyone try to install it with Ubuntu 17.10 ?


#44

We do not provide binaries for that OS. You can compile yourself. Have your tried? Any issues with that?


#45

wanna try, just wondering if it works with libboost1.62 ?


#46

Yes, it should work with libboost 1.62.


#47

okay, I tried compile with Kubuntu 17.10

here is cmake error:


#48

That is the vanilla SC3 source code without any additional packages?


#49

Hello,

Comenting line 114 in CMakeLists.txt (LIST(GET GCC_VERSION_COMPONENTS 1 GCC_VERSION_MINOR)) did the trick for me in Fedora 26.

The Deprecation Warning can be ignored.

Best regards,


#50

Thanks for the hint. What compiler is it using and what is the output of “gcc -dumpversion”?


#51

Hope it helps:

Fedora 26

$ gcc -v
Using built-in specs.
COLLECT_GCC=/usr/bin/gcc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-redhat-linux/7/lto-wrapper
OFFLOAD_TARGET_NAMES=nvptx-none
OFFLOAD_TARGET_DEFAULT=1
Target: x86_64-redhat-linux
Configured with: …/configure --enable-bootstrap --enable-languages=c,c++,objc,obj-c++,fortran,ada,go,lto --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-shared --enable-threads=posix --enable-checking=release --enable-multilib --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-linker-build-id --with-gcc-major-version-only --with-linker-hash-style=gnu --enable-plugin --enable-initfini-array --with-isl --enable-libmpx --enable-offload-targets=nvptx-none --without-cuda-driver --enable-gnu-indirect-function --with-tune=generic --with-arch_32=i686 --build=x86_64-redhat-linux
Thread model: posix
gcc version 7.1.1 20170622 (Red Hat 7.1.1-3) (GCC)


#52
gcc -dumpversion

Please use the command above. That is the command issued by cmake to query for the version.


#53

yes it is, no additional packages. it from master branch.


#54

Sorry, I forgot to copy that part :-((

$ gcc -dumpversion
7


#55

That explains it. It does not report the minor version number and therefor the index is out of range. Will fix it.


#56

@wewenk A fix has been pushed, please give it a try.


#57

another error, but it still can generating


#58

This is a warning. My fault, I have fixed it. Just a stupid typo.


#59

compiling success, seiscomp setup failed.


#60

That is related to the database setup. Have you MySQL or MariaDB installed? I haven’t installed that OS so I can’t help right now. You can check etc/init/scmaster.py and try to rerun the mysql command on the terminal. Maybe that helps to find the issue.